Local install for otterscan not going through


I just heard about Aztec on a podcast and was really excited about the privacy aspect and wanted to test it out locally!

I seem to be running into an issue with I run the cli to install Aztec locally. It seems to get hung up on this part:

Screenshot 2023-10-23 at 6.09.20 PM

The node version I’m using is 18 and I have Docker and Docker Compose installed on my machine globally.

Would love help trying to solve this so I can get to playing around on the network.

1 Like

Interesting, I haven’t seen this one yet. I’ll investigate further.

As a short term solution you can modify your docker-compose.yml file in ~/.aztec/, just remove the otterscan service from that file and then run

docker-compose up

in the ~/.aztec folder.

1 Like

hi @petermazzocco !

Can you elaborate more on the issue? Does the image pulling just hang indefinitely?

It seems to pull OK on my m1 right now, so I’m wondering if this is possibly flakiness - it’d be helpful to get a little more context to debug this

Just ran the docker-compose up and same issue… hangs up a96da7eb6f33

Hi Dan!

Yes so let me provide as much context as possible to see if maybe it’s just user error on my end. I also have a Macbook Pro M1 in case that needs to be noted.

What I am doing is opening a terminal and running the command /bin/bash -c "$(curl -fsSL 'https://sandbox.aztec.network')" per the documentation. Another thing I’ve done is I’ve also set up a FORK_URL using an Alchemy RPC URL, and the FORK_BLOCK_NUMBER is the one that’s set from the documentation.

When I run the curl command, it seems to get hung up on the otterscan layers, and will try to pull all but doesn’t seem to fully complete the process. I then get an error related to it timing out after around 200s.

It hangs even without otterscan?

Could you try the /bin/bash -c "$(curl -fsSL 'https://sandbox.aztec.network')" command, but without using the Alchemy RPC as the FORK_URL? I don’t think you need to explicitly set the FORK_BLOCK_NUMBER either - it should be OK to run without either environment variable set.

I think the main issue is the Alchemy RPC; the sandbox is meant to run against a local anvil instance of ethereum, rather than a testnet (or mainnet). So there’s no need for Alchemy to be involved at all.

Whoops, forgot to remove that. Just did and seemed to work just fine! Says:

aztec-aztec-1     | Aztec Sandbox v0.11.1 (nargo 0.17.0-aztec.2) is now ready for use!